Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1-ALPHA-37
    • Component/s: None
    • Labels:
      None

      Issue Links

        Activity

        fabrizio.giudici Fabrizio Giudici added a comment -
        Some tests fail.
        fabrizio.giudici Fabrizio Giudici added a comment -
        These are the failing tests:

        AvailabilityEnforcerRequestProcessorTest
        ScanningMetadataInterpolatorFactoryTest
        DefaultMetadataTest
        fabrizio.giudici Fabrizio Giudici added a comment - - edited
        For AvailabilityEnforcerRequestProcessorTest , the problem seems to be with mock objects created with Mockito.spy(). In existing code, @Getter and @Setter was provided too, and the test Spring configuration was explicitly setting the reference. Injecting by type was not working already with Spring 3. But now it seems that the presence of @Inject always tririggers injection. In fact, the thing works is @Inject is temporarily commented out. Disabling autowiring doesn't work.

        For ScanningMetadataInterpolatorFactory, the problem is that now java.lang.Object is also scanned, and its superclass is null.

        DefaultMetadataTest is ok now, probably fixed by changes for other issues.

          People

          • Assignee:
            fabrizio.giudici Fabrizio Giudici
            Reporter:
            fabrizio.giudici Fabrizio Giudici
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: