Details

    • Type: Defect (bug)
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1-ALPHA-27
    • Fix Version/s: 1.1-ALPHA-30
    • Component/s: Filesystems, Mercurial
    • Labels:
      None

      Description

      2:02:49.353 [scheduler-8 ] WARN i.t.n.f.filesystem.hg.MercurialFileSystemProvider - >>>> error when checking for updates
      java.io.IOException: Process exited with 255
              at it.tidalwave.northernwind.frontend.filesystem.hg.impl.ProcessExecutor.waitForCompletion(ProcessExecutor.java:319) ~[it-tidalwave-northernwind-core-filesystem-hg-1.0.10.jar:1.0.10.9eff475b20e6]
              at it.tidalwave.northernwind.frontend.filesystem.hg.impl.DefaultMercurialRepository.pull(DefaultMercurialRepository.java:188) ~[it-tidalwave-northernwind-core-filesystem-hg-1.0.10.jar:1.0.10.9eff475b20e6]
              at it.tidalwave.northernwind.frontend.filesystem.hg.MercurialFileSystemProvider.findNewTag(MercurialFileSystemProvider.java:216) ~[it-tidalwave-northernwind-core-filesystem-hg-1.0.10.jar:1.0.10.9eff475b20e6]
              at it.tidalwave.northernwind.frontend.filesystem.hg.MercurialFileSystemProvider.checkForUpdates(MercurialFileSystemProvider.java:144) ~[it-tidalwave-northernwind-core-filesystem-hg-1.0.10.jar:1.0.10.9eff475b20e6]
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_25]
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_25]
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_25]
              at java.lang.reflect.Method.invoke(Method.java:606) ~[na:1.7.0_25]
              at org.springframework.scheduling.support.ScheduledMethodRunnable.run(ScheduledMethodRunnable.java:64) ~[spring-context-3.1.0.RELEASE.jar:3.1.0.RELEASE]
              at org.springframework.scheduling.support.DelegatingErrorHandlingRunnable.run(DelegatingErrorHandlingRunnable.java:53) ~[spring-context-3.1.0.RELEASE.jar:3.1.0.RELEASE]
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) ~[na:1.7.0_25]
              at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:351) ~[na:1.7.0_25]
              at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178) ~[na:1.7.0_25]
              at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:178) ~[na:1.7.0_25]
              at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) ~[na:1.7.0_25]
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) ~[na:1.7.0_25]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) ~[na:1.7.0_25]
              at java.lang.Thread.run(Thread.java:724) ~[na:1.7.0_25]

        Activity

        fabrizio.giudici Fabrizio Giudici added a comment -
        Better diagnostics implemented - installed on one server, waiting for the bug to reproduce.
        fabrizio.giudici Fabrizio Giudici added a comment - - edited
        The patch for better diagnostics has been pushed to the branch fabrizio.giudici.
        fabrizio.giudici Fabrizio Giudici added a comment -
        The better diagnostic works - it turned out that the problem is due to the source repository being somewhere unavailable with HTTP status 500. So this wasn't really a bug.
        fabrizio.giudici Fabrizio Giudici added a comment -
        Marked closed in 1.1-ALPHA-30, where the better diagnostic patch was incorporated.

          People

          • Assignee:
            fabrizio.giudici Fabrizio Giudici
            Reporter:
            fabrizio.giudici Fabrizio Giudici
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: