Details

    • Type: Defect (bug)
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.0.290
    • Fix Version/s: 1.6.0
    • Component/s: codec, processor
    • Labels:
      None

      Description

      Unfortunately using the RAWProcessor with the reajent library/bundle is not possible. The reason for this is that the jrawio bundle imports the it.tidalwave.imageio.rawprocessor package (exported by the reajent bundle). As a result the jrawio bundle cannot see the RAWProcessorInstallerSpi class anymore and hence I cannot register that SPI class with ImageIO.

      The it.tidalwave.imageio.nef package has the same problem: exported by reajent, imported by jrawio causing the jrawio bundle to not see its own classes anymore.

      My solution to this problem is to create a single bundle containing both libraries (and not exporting anything at any more, since I have specialized code to register the SPI classes dynamically).

      Question: Can this problem be solved somehow, such that these two packages are not split in two bundles any more ?

      Thanks and Regards
      Felix

        Issue Links

          Activity

          Hide
          fabrizio.giudici Fabrizio Giudici added a comment -
          It has been decided (JRW-207) to distribute jrawio as a single jar file since 1.6.0. If 1.6.0 comes reasonably fast, we could close this issue.
          Show
          fabrizio.giudici Fabrizio Giudici added a comment - It has been decided ( JRW-207 ) to distribute jrawio as a single jar file since 1.6.0. If 1.6.0 comes reasonably fast, we could close this issue.
          Hide
          fabrizio.giudici Fabrizio Giudici added a comment -
          A preview of 1.6.0 is available here:

          http://jrawio.rawdarkroom.org/specifications/1.6/

          We would like to have a feedback on whether the OSGi thing has been fixed.
          Show
          fabrizio.giudici Fabrizio Giudici added a comment - A preview of 1.6.0 is available here: http://jrawio.rawdarkroom.org/specifications/1.6/ We would like to have a feedback on whether the OSGi thing has been fixed.
          Hide
          fabrizio.giudici Fabrizio Giudici added a comment -
          Thanks to a submitted patch, now it seems to work.
          Show
          fabrizio.giudici Fabrizio Giudici added a comment - Thanks to a submitted patch, now it seems to work.

            People

            • Assignee:
              fabrizio.giudici Fabrizio Giudici
              Reporter:
              fabrizio.giudici Fabrizio Giudici
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: